Installing MT4 Expert Advisors, Indicators and Scripts
This page describes how to install scripts, indicators and expert advisors purchased from the MT4-tools website.
The following steps are used to install the MT4 tools onto your Metatrader 4 terminal.
  • Open up your Metatrader 4 terminal.
  • Under the File menu, select "Open Data folder..."
"Open Data Folder" under the File menu
  • Windows explorer will open in the Metatrader 4 data folder, showing you sub-directories under the main level. Double click on "MQL4" to go up one more level.
Windows exploer when it first opens.
​
  • Double click on "MQL4" to go up one more level and you will see a series of folders including "Indicators", "Scripts" and "Experts".
​
Sub-Directories under MQL4
  • Copy the files received into the respective folder, depending on whether they are an indicator, script or expert advisor.
  • Close your Metatrader 4 terminal and then reopen again.
  • Open the navigator in the Metatrader 4 terminal (CTRL-N) and look under the respective section to see if the indicators, scripts or expert advisor can be seen.
  • Lastly, under the "Tools" menu, select "Options" to bring up various settings you can change for your Metatrader 4 terminal.
Select options under the Tools menu
​
  • Under the Experts tab, ensure the checkbox labelled "Allow DLL imports" is ticked and click on OK.
Ensure "Allow DLL imports" is ticked
Copy link